Принтер Epson L1300

YNA

New member
Сообщения
31
#1
Здравствуйте уважаемые участники форума.
Помогите пожалуйста с установкой принтера Epson L1300. При поиске принтера система правильно отображает его название и предлагает установить драйвер, но в появляющемся списке принтеров Epson L1300 нет. На сайте Epson, правда где то "слева" выложены драйвера под Линукс. После установки этого драйвера в принтере появились вроде все настройки, но печать не идёт - статус печать Остановлена. Что можно сделать?
Система Астра - Орёл 2.12.14, вот только сегодня обновилась, но на налаживание принтера это обновление ни как не повлияло - по-прежнему не печатает. ;(
 

Olej

New member
Сообщения
1 010
#2
На сайте Epson, правда где то "слева" выложены драйвера под Линукс. После установки этого драйвера в принтере появились вроде все настройки, но печать не идёт - статус печать Остановлена.
1. покажите URL где "выложены";
2. как устанавливали?
3. покажите lsusb (принтер USB?), чтобы быть уверенным, что "система правильно отображает его название";
 

YNA

New member
Сообщения
31
#3
Что то не могу найти адрес. Сам драйвер "epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb" и ещё такой же с расширением rpm.
Устанавливался через настройку принтера и установку драйвера, система запросила файл с расширением *.ppds.
Файл приложен. Если его распаковать, то там можно найти файлик с расширением *.ppds
 

Вложения

Olej

New member
Сообщения
1 010
#4
Сам драйвер "epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb" и ещё такой же с расширением rpm.
"Гложут меня сомнения..." :D

Во-первых ... i386 - это, обычно, суффикс для 32-битных компонент Linux, а Astra существует (во всех реинкарнациях) только как 64-бит система ... но, может и не так;
Во-вторых, .rpm - это для RPM дистрибутивов (Fedora, RedHat, ...) - к вам это совсем не относится;
В-третьих, ... если уж это .deb, то устанавливаться он должен стандартно, утилитой dpkg, а не какими-то там фокусами...
И, наконец, .ppds к самому драйверу устройства ну точно не имеет никакого отношения.

P.S. вы пишете про epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb, а прикладываете epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.zip :oops: ... или по-вашему оно всё равно? :D

P.P.S.
Что то не могу найти адрес.
А ссылки надо сохранять!
Потому что здесь вам не Windows, где воруют все и откуда попало :cry: ... здесь вы никогда не разберётесь до конца, если не будете точно знать происхождение...
;)
 
Последнее редактирование:

YNA

New member
Сообщения
31
#5
Так вот в том то и дело, что Windows 10. Вся история страниц из соображений конфиденциальности сразу удаляется по выходу из браузера, по этому трудно искать. :)
А вот иллюстрация как это всё устанавливалось. Наверняка неправильно и есть наверное правильный способ, но я не умею :(
А как можно по другому установить принтер?
Снимок.jpg
 

Olej

New member
Сообщения
1 010
#6
А как можно по другому установить принтер?
Не принтер, а пакет .deb - если вы считаете, что это пакет для вашего принтера.

P.S. вы пишете про epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb, а прикладываете epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.zip :oops: ... или по-вашему оно всё равно? :D
А ... понял, у вас .deb запакован в .zip ...
Только ваш пакет .deb не устанавливается в Astra CE:
Код:
olej@astra:~/Загрузки$ sudo dpkg -i epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb
Выбор ранее не выбранного пакета epson-inkjet-printer-201311w:i386.
(Чтение базы данных … на данный момент установлено 231265 файлов и каталогов.)
Подготовка к распаковке epson-inkjet-printer-201311w_1.0.1-1lsb3.2_i386.deb …
Распаковывается epson-inkjet-printer-201311w:i386 (1.0.1-1lsb3.2) …
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-201311w:i386:
epson-inkjet-printer-201311w:i386 зависит от lsb (>= 3.2).

dpkg: ошибка при обработке пакета epson-inkjet-printer-201311w:i386 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
epson-inkjet-printer-201311w:i386
Ошибочка-с ...
И вы его не могли никак установить...
 

Montfer

New member
Сообщения
462
#7
Пробуйте http://download.ebz.epson.net/dsc/search/01/search/
Там вобьете вашу модель и ОС (Linux)
Найдет две утилиты - которая из них ваша - хз. И там, и там есть для x64 систем. Ну, и перед установкой драйвера надо поставить lsb...
Будет или не работать с ним - хз
 

YNA

New member
Сообщения
31
#8
Да, печалька.
Но кое что интересно, нужно будет научиться Судя по рисунку в командной строке нужно напечатать фразу "sudo dpkg -i", а потом через пробел точное имя файла и начнётся автоматическая установка программы (или драйвера). Так?
А вот интересно, можно ли найти драйверы в репозитории, откуда скачиваются программы и обновления?

И ещё. Параллельно стоит Альт Линукс. Он сразу правильно определил всё оборудование и корректно установил. Можно ли как то забраться в его файловую систему и оттуда вытянуть програмки/драйвера на принтер (ну за одно и на другие "неудавшиеся" устройства), или эти системы несовместимы?

Опс, уже новый ответ появился, но только вечером смогу проверить.
 

Montfer

New member
Сообщения
462
#10
"Пробуйте http://download.ebz.epson.net/dsc/search/01/search/"

Дв, спасибо.
Но про эту ссылку я знаю и она вроде не рабочая, а вот ту, с которой скачивался драйвер что то не могу найти :(
странно, что она у вас нерабочая. Перешел по ссылке и скачал файл epson-printer-utility_1.1.0-1lsb3.2_amd64.deb
 

Olej

New member
Сообщения
1 010
#11
Никакой такой печальки...
Просто вы должны полюбить командную строку. ;)
А вот интересно, можно ли найти драйверы в репозитории, откуда скачиваются программы и обновления?
В репозиториях содержаться только пакеты, а не всё что попало...
В составе некоторых пакетов, там где это требуется (редко) могут быть и требуемые драйверы.
Можно ли как то забраться в его файловую систему и оттуда вытянуть програмки/драйвера на принтер (ну за одно и на другие "неудавшиеся" устройства), или эти системы несовместимы?
Не нужно этого делать!
Все Linux системы совместимы на уровне бинарных утилит, ... но только вы никогда не узнаете полный состав того, что вам требуется. И тем разрушите целостность системы.
 

Olej

New member
Сообщения
1 010
#12
Но про эту ссылку я знаю и она вроде не рабочая, а вот ту, с которой скачивался драйвер что то не могу найти
Вот ваш драйвер по этой ссылке:
L1300 Series Printer DriverLinux 1.1.0 Epson Printer Utility All language 08-01-2019
Код:
olej@astra:~/Загрузки$ ls -l epson-printer-utility_1.1.0-1lsb3.2_amd64.deb
-rw-r--r-- 1 olej olej 1283544 Авг  8 13:59 epson-printer-utility_1.1.0-1lsb3.2_amd64.deb
И конечно это радикально отличается от всего, что вы показывали ранее - и по имени, и по размеру...
 
Последнее редактирование:

Olej

New member
Сообщения
1 010
#13
Код:
olej@astra:~/Загрузки$ sudo apt install lsb
[sudo] пароль для olej:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «lsb» выбирается «lsb-compat»
НОВЫЕ пакеты, которые будут установлены:
  lsb-compat
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 28,3 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 70,7 kB.
Пол:1 https://download.astralinux.ru/astra/testing/orel/repository orel/main amd64 lsb-compat amd64 9.20161125 [28,3 kB]
Получено 28,3 kБ за 0с (72,9 kБ/c)
Выбор ранее не выбранного пакета lsb-compat.
(Чтение базы данных … на данный момент установлено 231820 файлов и каталогов.)
Подготовка к распаковке …/lsb-compat_9.20161125_amd64.deb …
Распаковывается lsb-compat (9.20161125) …
Настраивается пакет lsb-compat (9.20161125) …
Обрабатываются триггеры для man-db (2.7.6.1-2) …
Код:
olej@astra:~/Загрузки$ sudo dpkg -i epson-printer-utility_1.1.0-1lsb3.2_amd64.deb
Выбор ранее не выбранного пакета epson-printer-utility.
(Чтение базы данных … на данный момент установлено 231832 файла и каталога.)
Подготовка к распаковке epson-printer-utility_1.1.0-1lsb3.2_amd64.deb …
Распаковывается epson-printer-utility (1.1.0-1lsb3.2) …
Настраивается пакет epson-printer-utility (1.1.0-1lsb3.2) …
Install Message > Described entry of LITE in services.
Install Message > Backup file is /etc/services.bak.
Install Message > Start /usr/lib/epson-backend/setup to change setup.
Вот теперь, по крайней мере, всё встаёт без ошибок.
 

Olej

New member
Сообщения
1 010
#14
в том то и дело, что Windows 10.
У вас Astra Linux в виртуальной машине?
Тогда совершенно не обязательно, что если вы даже идеально установите принтер (или любое другое периферийное устройство, реальное) - что оно будет работать.
 

YNA

New member
Сообщения
31
#16
Всем огромное спасибо за помощь!
Вечером попробую установить. В любом случае обязательно отпишусь.
 

YNA

New member
Сообщения
31
#17
"... Astra Linux в виртуальной машине?…"

Виртуальных машин у меня нет. Все три системы установлены на разных дисках и запускаются с загрузчика GRUB от Альт Линукс К8.3.
Почему этот загрузчик стал приоритетным даже не знаю. Скорее всего потому что загрузчик Астры не нашёл Винду и видел только Альт. Потом пришлось загружать Альт и из него восстанавливать мульти загрузку всех трёх систем. Кстати, после сегодняшнего обновления до 2.12.14 в настройках загрузчика Астры появилась Windows 10, но ни чего менять не хочу, а то вдруг что то поломаю и моя сменшица будет крайне недовольна, если комп по умолчанию будет грузиться в Линукс, а фиксить MBR довольно хлопотное занятие и смертельное для линукс систем :(
 

Olej

New member
Сообщения
1 010
#19
а вы уверены, что lsb-compat подойдет?
Я ни в чём не уверен, но lsb - в репозитории Astra Орёл & Debian 9 - виртуальный пакет, и при установке именно его (по имени lsb) предоставляется (устанавливается) пакет lsb-compat.
Код:
olej@astra:~$ aptitude show lsb-compat
Пакет: lsb-compat                               
Версия: 9.20161125
Новый: да
Состояние: установлен
Установлен автоматически: нет
Приоритет: дополнительный
Раздел: misc
Сопровождающий: Debian LSB Team <debian-lsb@lists.debian.org>
Архитектура: amd64
Размер в распакованном виде: 70,7 k
Зависит: lsb-release (>= 9.20161125), lsb-base (>= 9.20161125), libc6 (>= 2.13-17), python3:any (>= 3.4~), libc6:i386 | libc6-i386,
         zlib1g:i386 | lib32z1, libcups2, libcupsimage2, ghostscript, cups-filters (>= 1.0.36)
Конфликтует: lsb, lsb-core, lsb:i386, lsb-core:i386, lsb-compat:i386
Заменяет: lsb, lsb-core, lsb:i386, lsb-core:i386
Предоставляет: lsb (= 4.1), lsb-core (= 4.1)
Описание: Linux Standard Base Compatibility
 The Linux Standard Base (http://www.linuxbase.org/) was a standard core system that third-party applications written for Linux could
 depend upon.
 
 This package provides the most minimal layer to be able to install and run selected legacy LSB packages on Debian.
Домашняя страница: http://www.linuxfoundation.org/collaborate/workgroups/lsb
 

Montfer

New member
Сообщения
462
#20
Я ни в чём не уверен, но lsb - в репозитории Astra Орёл & Debian 9 - виртуальный пакет, и при установке именно его (по имени lsb) предоставляется (устанавливается) пакет lsb-compat.
Код:
olej@astra:~$ aptitude show lsb-compat
Пакет: lsb-compat                             
Версия: 9.20161125
Новый: да
Состояние: установлен
Установлен автоматически: нет
Приоритет: дополнительный
Раздел: misc
Сопровождающий: Debian LSB Team <debian-lsb@lists.debian.org>
Архитектура: amd64
Размер в распакованном виде: 70,7 k
Зависит: lsb-release (>= 9.20161125), lsb-base (>= 9.20161125), libc6 (>= 2.13-17), python3:any (>= 3.4~), libc6:i386 | libc6-i386,
         zlib1g:i386 | lib32z1, libcups2, libcupsimage2, ghostscript, cups-filters (>= 1.0.36)
Конфликтует: lsb, lsb-core, lsb:i386, lsb-core:i386, lsb-compat:i386
Заменяет: lsb, lsb-core, lsb:i386, lsb-core:i386
Предоставляет: lsb (= 4.1), lsb-core (= 4.1)
Описание: Linux Standard Base Compatibility
The Linux Standard Base (http://www.linuxbase.org/) was a standard core system that third-party applications written for Linux could
depend upon.

This package provides the most minimal layer to be able to install and run selected legacy LSB packages on Debian.
Домашняя страница: http://www.linuxfoundation.org/collaborate/workgroups/lsb
понял, спасибо.
Я пошел другим путем, в итоге мне установилось полинтернета...

admpc@server:~$ sudo su
root@server:/home/admpc# echo deb http://ftp.ru.debian.org/debian jessie main >> /etc/apt/sources.list.d/debian.list
root@server:/home/admpc# exit
exit
admpc@server:~$ sudo apt update
Игн:1 http://ftp.ru.debian.org/debian jessie InRelease
Пол:2 http://ftp.ru.debian.org/debian jessie Release [77,3 kB]
Пол:3 http://linux.teamviewer.com/deb stable InRelease [9 388 B]
Пол:4 http://ftp.ru.debian.org/debian jessie Release.gpg [1 652 B]
Сущ:5 https://download.astralinux.ru/astra/stable/orel/repository orel InRelease
Пол:6 http://ftp.ru.debian.org/debian jessie/main amd64 Packages [6 818 kB]
Пол:7 http://ftp.ru.debian.org/debian jessie/main i386 Packages [6 821 kB]
Пол:8 http://ftp.ru.debian.org/debian jessie/main Translation-ru [438 kB]
Пол:9 http://ftp.ru.debian.org/debian jessie/main Translation-en [4 581 kB]
Получено 18,7 MБ за 34с (548 kБ/c)
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлён 1 пакет. Запустите «apt list --upgradable» для показа.
admpc@server:~$ sudo apt install lsb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
alien at autoconf automake autopoint autotools-dev build-essential debhelper debugedit dh-autoreconf dh-strip-nondeterminism
dpkg-dev ed g++ g++-6 gettext intltool-debian libalgorithm-diff-perl libalgorithm-merge-perl libarchive-zip-perl libdpkg-perl
libfile-stripnondeterminism-perl libltdl-dev liblua5.2-0 libmail-sendmail-perl libpango1.0-0 libpangox-1.0-0 libpng12-0
libpod-plainer-perl libqt3-mt librpm3 librpmbuild3 librpmio3 librpmsign3 libstdc++-6-dev libsys-hostname-long-perl
libtimedate-perl libtool lsb-core lsb-cxx lsb-desktop lsb-graphics lsb-languages lsb-multimedia lsb-printing lsb-security m4
patch pax po-debconf rpm rpm-common rpm2cpio rsync time
Предлагаемые пакеты:
lintian autoconf-archive gnu-standards autoconf-doc dh-make rpm-i18n debian-keyring g++-multilib g++-6-multilib gcc-6-doc
libstdc++6-6-dbg gettext-doc libasprintf-dev libgettextpo-dev libtool-doc libqt3-mt-psql libqt3-mt-mysql libqt3-mt-odbc
libstdc++-6-doc gfortran | fortran95-compiler gcj-jdk m4-doc diffutils-doc libmail-box-perl elfutils rpmlint rpm2html
Рекомендуемые пакеты:
libalgorithm-diff-xs-perl libfile-fcntllock-perl
НОВЫЕ пакеты, которые будут установлены:
alien at autoconf automake autopoint autotools-dev build-essential debhelper debugedit dh-autoreconf dh-strip-nondeterminism
dpkg-dev ed g++ g++-6 gettext intltool-debian libalgorithm-diff-perl libalgorithm-merge-perl libarchive-zip-perl libdpkg-perl
libfile-stripnondeterminism-perl libltdl-dev liblua5.2-0 libmail-sendmail-perl libpango1.0-0 libpangox-1.0-0 libpng12-0
libpod-plainer-perl libqt3-mt librpm3 librpmbuild3 librpmio3 librpmsign3 libstdc++-6-dev libsys-hostname-long-perl
libtimedate-perl libtool lsb lsb-core lsb-cxx lsb-desktop lsb-graphics lsb-languages lsb-multimedia lsb-printing lsb-security m4
patch pax po-debconf rpm rpm-common rpm2cpio rsync time
обновлено 0, установлено 56 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
Необходимо скачать 30,1 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 82,8 MB.
Хотите продолжить? [Д/н] y

admpc@server:~$ sudo dpkg -i /home/admpc/Загрузки/epson-printer-utility_1.1.0-1lsb3.2_amd64.deb
sudo: unable to resolve host server.local
Выбор ранее не выбранного пакета epson-printer-utility.
(Чтение базы данных … на данный момент установлено 177763 файла и каталога.)
Подготовка к распаковке …/epson-printer-utility_1.1.0-1lsb3.2_amd64.deb …
Распаковывается epson-printer-utility (1.1.0-1lsb3.2) …
Настраивается пакет epson-printer-utility (1.1.0-1lsb3.2) …
Install Message > Described entry of LITE in services.
Install Message > Backup file is /etc/services.bak.
Install Message > Start /usr/lib/epson-backend/setup to change setup.
admpc@server:~$