HP LJ Pro M104a

Alexls

New member
Сообщения
1
#1
Имеется
1. Смоленск 1.5 Сертификат ФСБ
2. Принтер HP LJ Pro M104a

В дистрибутиве имеется Hplip 3.15.11
Минимальная версия Hplip для принтера 3.16.11

Вопрос - где можно взять Hplip версии 3.16.11 или выше не нарушающий условия сертификации
 

Rimskii

New member
Сообщения
5
#2
Добрый день, та же проблема, не можем подцепить принтер HP LJ Pro M104a Ставили 3,19 и 3,16 не видит принтера. Есть у кого нибудь внятные инструкции на подключение данного принтера ?
 

Olej

New member
Сообщения
1 203
#3
та же проблема, не можем подцепить принтер HP LJ Pro M104a Ставили 3,19 и 3,16 не видит принтера. Есть у кого нибудь внятные инструкции на подключение данного принтера ?
1. начните с того какой дистрибутив Astra Linux вас интересует?
2. никакой "инструкции" по конкретной, частной модели HP LJ Pro M104a нет и быть не может, HP очень не любит Linux со своим оборудованием и ничего не гарантирует, ... ищите описания для аналогичных моделей
3. посмотрите принтер HP LJ P1102 - может, по аналогии, чего-то подскажет.
 

Rimskii

New member
Сообщения
5
#4
1. начните с того какой дистрибутив Astra Linux вас интересует?
2. никакой "инструкции" по конкретной, частной модели HP LJ Pro M104a нет и быть не может, HP очень не любит Linux со своим оборудованием и ничего не гарантирует, ... ищите описания для аналогичных моделей
3. посмотрите принтер HP LJ P1102 - может, по аналогии, чего-то подскажет.
Добрый день стоит астра 1.5
Соответсвенно стандартный пакет hp lip 3.15
Вроде говорят с 3.16 этот принтер будет работать. Подскажите как обновить его до 3.16 ахривы с сайта почему то не устанавливаются. Для меня это не профильное по. Но если напишите какими командами и где можно скачать был бы признателен.
 

Olej

New member
Сообщения
1 203
#5
Добрый день стоит астра 1.5
Нет такой ;), есть Astra CE 2.12.14 или Astra SE 1.5 ... но, в общем, понятно.
не нарушающий условия сертификации
Вам ведь тоже "не нарушающий условия сертификации"? :)
Не знаю. Ничего не знаю про условия сертификации...
 

Olej

New member
Сообщения
1 203
#7
Да нам бы хотяб чтобы подружился.
Вот то, что есть у вас в Astra Linuux CE (Орёл), чтобы далеко не ходить, в стандартном сетевом их репозитории :
Код:
olej@astra:~$ aptitude search hplip
i   hplip                                                     - система печати и сканирования HP (HPLIP)                          
p   hplip:i386                                                - система печати и сканирования HP (HPLIP)                          
i A hplip-data                                                - система печати HPLIP — файлы данных                                
p   hplip-doc                                                 - система печати HPLIP — документация                                
v   hplip-doc:i386                                            -                                                                    
i   hplip-gui                                                 - система печати HPLIP — инструменты с графическим интерфейсом (на осн
v   hplip-ppds                                                -
Код:
olej@astra:~$ aptitude show hplip
Пакет: hplip                                    
Версия: 3.18.12+dfsg0-1astra5
Состояние: установлен
Установлен автоматически: нет
Приоритет: необязательный
Раздел: utils
Сопровождающий: Debian Printing Team <debian-printing@lists.debian.org>
Архитектура: amd64
Размер в распакованном виде: 1.864 k
Зависит: adduser, cups, hplip-data (= 3.18.12+dfsg0-1astra5), libhpmud0 (= 3.18.12+dfsg0-1astra5), libsane-hpaio (= 3.18.12+dfsg0-1astra5),
         lsb-base, printer-driver-hpcups (= 3.18.12+dfsg0-1astra5), python3-dbus, python3-gi, python3-pexpect, python3-pil,
         python3-reportlab, wget, python3 (< 3.6), xz-utils, python3 (>= 3.5~), libc6 (>= 2.14), libcups2 (>= 1.6.0), libdbus-1-3 (>=
         1.9.14), libpython3.5 (>= 3.5.0~b1), libsane (>= 1.0.24), libsnmp30 (>= 5.7.3+dfsg-1.7+deb9u1~dfsg), libusb-1.0-0 (>= 2:1.0.8)
Рекомендует: avahi-daemon, policykit-1, printer-driver-postscript-hp, sane-utils
Предлагает: hplip-doc, hplip-gui, python3-notify2, system-config-printer
Конфликтует: hplip:i386
Описание: система печати и сканирования HP (HPLIP)
Система печати HPLIP (HP Linux Printing and Imaging System) предназначена для работы с принтерами и МФУ (многофункциональные устройства)
производства фирмы Hewlett-Packard. Она поддерживает печать на большинстве струйных и многих лазерных (LaserJet) принтерах, а также
сканирование, отправку факсов и работу с картами памяти (с фотографиями) на большинстве МФУ.

HPLIP включает в себя:
* системные службы для связи с принтерами
* драйвер CUPS (hp:) для двустороннего взаимодействия с принтерами HP (позволяет CUPS получать информацию о состоянии принтера и дополняет
   HPIJS, например, позволяет печатать в край со всех сторон)
* драйвер CUPS для отправки факсов (hpfax:)
* драйвер hpcups для преобразования растровых изображений, получаемых из цепочки фильтров CUPS во внутренний формат принтера (PCL, LIDIL,
   ...) (hpcups выделен в отдельный пакет)
* драйвер HPIJS Ghostscript IJS для растеризации из файлов PostScript™ или из любого другого формата источника, поддерживающегося
   Ghostscript, а также для преобразования факсов в PostScript™ (HPIJS поставляется в отдельном пакете)
* утилиты командной строки для обслуживания принтеров, например, для слежения за количеством чернил или очистки головки и калибровки
* утилиты командной строки и графический интерфейс для скачивания данных с карт памяти, вставляемых в устройства МФУ
* утилиты командной строки и графический интерфейс для работы с факсом
* графическая инструментальная панель для доступа сразу ко всем этим функциям
* драйвер HPAIO для SANE (hpaio), поддерживающий сканирование в устройствах МФУ планшетного типа и с автоматической подачей документа
 
Поддерживаются устройства с подключением по USB, JetDirect (по сети) и по параллельному порту.
Домашняя страница: https://developers.hp.com/hp-linux-imaging-and-printing
Метки: hardware::printer, implemented-in::python, interface::daemon, network::server, protocol::ssl, role::program, use::driver,
       use::printing
Версия 3.18.
Если оно есть в Astra Linux CE, то оно должно быть и в Astra Linux SE, на диске разработчика ... или требуйте с дистрибьютора.
А если вам наплевать на сертификацию, то скачайте по прямой ссылке с репозитория Astra Linux CE, и установите вручную.
Вот здесь вам: https://mirror.yandex.ru/astra/stable/orel/repository/pool/main/h/hplip/ - 3.18
Код:
hpijs-ppds_3.18.12+dfsg0-1astra5_all.deb                                                                                 20-Dec-2018 18:58     90K
hplip-data_3.18.12+dfsg0-1astra5_all.deb                                                                                 20-Dec-2018 18:58     16M
hplip-doc_3.18.12+dfsg0-1astra5_all.deb                                                                                  20-Dec-2018 18:58    656K
hplip-gui_3.18.12+dfsg0-1astra5_all.deb                                                                                  20-Dec-2018 18:58     99K
hplip_3.18.12+dfsg0-1astra5.debian.tar.xz                                                                                22-Mar-2019 11:50      9M
hplip_3.18.12+dfsg0-1astra5.dsc                                                                                          22-Mar-2019 11:50    2225
hplip_3.18.12+dfsg0-1astra5_amd64.deb                                                                                    20-Dec-2018 18:58      1M
hplip_3.18.12+dfsg0.orig.tar.xz                                                                                          10-Dec-2018 15:35      9M
libhpmud-dev_3.18.12+dfsg0-1astra5_amd64.deb                                                                             20-Dec-2018 18:58     89K
libhpmud0_3.18.12+dfsg0-1astra5_amd64.deb                                                                                20-Dec-2018 18:58    180K
libsane-hpaio_3.18.12+dfsg0-1astra5_amd64.deb                                                                            20-Dec-2018 18:58    200K
printer-driver-hpcups_3.18.12+dfsg0-1astra5_amd64.deb                                                                    20-Dec-2018 18:58    340K
printer-driver-hpijs_3.18.12+dfsg0-1astra5_amd64.deb                                                                     20-Dec-2018 18:58    361K
printer-driver-postscript-hp_3.18.12+dfsg0-1astra5_amd64.deb                                                             20-Dec-2018 18:58      1M
 
Последнее редактирование:

Olej

New member
Сообщения
1 203
#9
P.S. Но по ссылке, которую я показывал выше, упоминается HPLIP и версий 4. Можно бы поискать и попробовать.
Но это по "обсуждениям народным", а на самом сайте HP (на странице hplip) оригинальная последняя версия 3.19.6 обновлённая 2019-06-27:
Код:
olej@ACER:~/Загрузки$ ls -l hplip-3.19.6.run
-rw-r--r-- 1 olej olej 25446343 июл 10 17:30 hplip-3.19.6.run
Можете просто скачать оттуда файл (как я сделал чтоб показать вам выше ;)) + попробовать запустить его на выполнение (если вам пока по хер "условия сертификации").
 

Montfer

New member
Сообщения
554
#10
Добрый день стоит астра 1.5
Соответсвенно стандартный пакет hp lip 3.15
Вроде говорят с 3.16 этот принтер будет работать. Подскажите как обновить его до 3.16 ахривы с сайта почему то не устанавливаются. Для меня это не профильное по. Но если напишите какими командами и где можно скачать был бы признателен.
Напишите в тех.поддержку, возможно, они сделают вам пакет для установки