Viber

Сообщения
1
#21
Странно, установил не очень давно пакет viber для ubuntu — работает нормально, проблем по сей день не замечено.
можно ссылку для скачивания, пожалуйста. В школе раздали ноутбуки, как хочешь так работай с детьми на дистанте. Ни зум, ни вайбер не могу установить
 

Mischutka

New member
Сообщения
180
#22
можно ссылку для скачивания, пожалуйста. В школе раздали ноутбуки, как хочешь так работай с детьми на дистанте. Ни зум, ни вайбер не могу установить
Ссылку не помню. Попробую сюда deb-пакет залить. Файл слишком большой для загрузки. Попробуйте тогда эту ссылку: http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
 

DEVOPS

New member
Сообщения
39
#23
в чём может быть дело?
viber установился но, не запускается на astra linux орёл
 

Olej

New member
Сообщения
1 248
#25
viber установился но, не запускается на astra linux орёл
Не совсем понятно как у вас Viber установился в Орёл ... (дайте версию Орёл)
Код:
olej@astra:~$ inxi -Sxxx
System:    Host: astra Kernel: 4.19.0-1-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: N/A dm: N/A Distro: Astra Linux (Orel 2.12.43)
          
olej@astra:~/Загрузки$ sudo dpkg -i viber.deb
[sudo] пароль для olej:
Попробуйте ещё раз.
[sudo] пароль для olej:
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 187746 файлов и каталогов.)
Подготовка к распаковке viber.deb …
Распаковывается viber (16.1.0.37) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libxcb-xinput0, однако:
  Пакет libxcb-xinput0 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1astra1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber
Вот и вся "установка" ... если из последней версии Viber.

Viber вообще изготовлен на редкость плохо, а в Linux - особенно! В одних дистрибутивах он устанавливается, в других нет, в некоторых установившись тут же падает в кору...
 
Последнее редактирование:

DEVOPS

New member
Сообщения
39
#26
Не совсем понятно как у вас Viber установился в Орёл ... (дайте версию Орёл)
Код:
olej@astra:~$ inxi -Sxxx
System:    Host: astra Kernel: 4.19.0-1-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: N/A dm: N/A Distro: Astra Linux (Orel 2.12.43)
         
olej@astra:~/Загрузки$ sudo dpkg -i viber.deb
[sudo] пароль для olej:
Попробуйте ещё раз.
[sudo] пароль для olej:
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 187746 файлов и каталогов.)
Подготовка к распаковке viber.deb …
Распаковывается viber (16.1.0.37) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
viber зависит от libxcb-xinput0, однако:
  Пакет libxcb-xinput0 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1astra1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
viber
Вот и вся "установка" ... если из последней версии Viber.

Viber вообще изготовлен на редкость плохо, а в Linux - особенно! В одних дистрибутивах он устанавливается, в других нет, в некоторых установившись тут же падает в кору...
дока
установка вайбера который ставится но не запускается
 

DEVOPS

New member
Сообщения
39
#27
Чтоб всё работало. И все пакеты были новые и актуальные, обновляем репы в /etc/apt/sources.list
Код:
deb http://httpredir.debian.org/debian stretch main contrib non-free
deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
После этих обновлений, обновляем дальше sudo nano /etc/apt/sources.list:
Код:
deb http://httpredir.debian.org/debian buster  main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free
sudo apt-get update
sudo apt-get upgrade
sudo apt-get full-upgrade

Не забываем перед этим делать бекап!!!
 

Olej

New member
Сообщения
1 248
#28

Olej

New member
Сообщения
1 248
#29
А вот заметки (мытарства) как я устанавливал и заставил работать последний (несколько дней назад) Viber в дистрибутиве antiX совместимом в Debian - можете посмотреть (и повторить попытаться) здесь - antiX - слабые компьютеры:
Код:
$ inxi -Sxxx
System:
  Host: antix21 Kernel: 4.9.0-279-antix.1-amd64-smp arch: x86_64 bits: 64
    compiler: gcc v: 10.2.1 Desktop: IceWM v: 2.9.7 vt: 7 dm: slimski v: 1.5.0
    Distro: antiX-21_x64-base Grup Yorum 31 October 2021
    base: Debian GNU/Linux 11 (bullseye)
Код:
$ sudo dpkg -i viber.deb
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 112034 файла и каталога.)
Подготовка к распаковке viber.deb …
Распаковывается viber (16.1.0.37) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от gstreamer1.0-plugins-ugly, однако:
  Пакет gstreamer1.0-plugins-ugly не установлен.
 viber зависит от gstreamer1.0-pulseaudio, однако:
  Пакет gstreamer1.0-pulseaudio не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1) …
Обрабатываются триггеры для mailcap (3.69) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 viber
... а теперь дальше начинается ручная дрочиловка ... причём это проблемы не мои, и не сборщиков дистрибутива, а криворуких создателей Viber!
 

Olej

New member
Сообщения
1 248
#30
а теперь дальше начинается ручная дрочиловка
Код:
$ sudo apt install gstreamer1.0-plugins-ugly
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
gstreamer1.0-plugins-ugly : Зависит: liba52-0.7.4 (>= 0.7.4) но он не будет установлен
                             Зависит: libmpeg2-4 (>= 0.5.1) но он не будет установлен
viber : Зависит: gstreamer1.0-pulseaudio но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
Код:
$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio liba52-0.7.4 libmpeg2-4
Следующие НОВЫЕ пакеты будут установлены:
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio liba52-0.7.4 libmpeg2-4
Обновлено 0 пакетов, установлено 4 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
Необходимо скачать 1 842 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 2 737 kB.
Хотите продолжить? [Д/н] y
Пол:1 http://ftp.de.debian.org/debian bullseye/main amd64 liba52-0.7.4 amd64 0.7.4-20 [31,4 kB]
Пол:2 http://ftp.de.debian.org/debian bullseye/main amd64 libmpeg2-4 amd64 0.5.1-9 [55,7 kB]
Пол:3 http://ftp.de.debian.org/debian bullseye/main amd64 gstreamer1.0-plugins-ugly amd64 1.18.4-2 [395 kB]
Пол:4 http://ftp.de.debian.org/debian bullseye/main amd64 gstreamer1.0-pulseaudio amd64 1.18.4-2 [1 360 kB]
Получено 1 842 kB за 1с (1 333 kB/s)
Выбор ранее не выбранного пакета liba52-0.7.4:amd64.
(Чтение базы данных … на данный момент установлено 113478 файлов и каталогов.)
Подготовка к распаковке …/liba52-0.7.4_0.7.4-20_amd64.deb …
Распаковывается liba52-0.7.4:amd64 (0.7.4-20) …
Выбор ранее не выбранного пакета libmpeg2-4:amd64.
Подготовка к распаковке …/libmpeg2-4_0.5.1-9_amd64.deb …
Распаковывается libmpeg2-4:amd64 (0.5.1-9) …
Выбор ранее не выбранного пакета gstreamer1.0-plugins-ugly:amd64.
Подготовка к распаковке …/gstreamer1.0-plugins-ugly_1.18.4-2_amd64.deb …
Распаковывается gstreamer1.0-plugins-ugly:amd64 (1.18.4-2) …
Выбор ранее не выбранного пакета gstreamer1.0-pulseaudio:amd64.
Подготовка к распаковке …/gstreamer1.0-pulseaudio_1.18.4-2_amd64.deb …
Распаковывается gstreamer1.0-pulseaudio:amd64 (1.18.4-2) …
Настраивается пакет libmpeg2-4:amd64 (0.5.1-9) …
Настраивается пакет liba52-0.7.4:amd64 (0.7.4-20) …
Настраивается пакет gstreamer1.0-plugins-ugly:amd64 (1.18.4-2) …
Настраивается пакет gstreamer1.0-pulseaudio:amd64 (1.18.4-2) …
Настраивается пакет viber (16.1.0.37) …
Обрабатываются триггеры для libc-bin (2.31-13+deb11u3) …
Код:
$ ./Viber
./Viber: error while loading shared libraries: libxslt.so.1: cannot open shared object file: No such file or directory
Код:
$ sudo apt install libxslt1.1
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Следующие НОВЫЕ пакеты будут установлены:
  libxslt1.1
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
Необходимо скачать 239 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 510 kB.
Пол:1 http://ftp.de.debian.org/debian bullseye/main amd64 libxslt1.1 amd64 1.1.34-4 [239 kB]
Получено 239 kB за 0с (512 kB/s)
Выбор ранее не выбранного пакета libxslt1.1:amd64.
(Чтение базы данных … на данный момент установлено 113562 файла и каталога.)
Подготовка к распаковке …/libxslt1.1_1.1.34-4_amd64.deb …
Распаковывается libxslt1.1:amd64 (1.1.34-4) …
Настраивается пакет libxslt1.1:amd64 (1.1.34-4) …
Обрабатываются триггеры для libc-bin (2.31-13+deb11u3) …
И только теперь можете запускать:
Код:
olej@antix21:/opt/viber
$ ./Viber
 

DEVOPS

New member
Сообщения
39
#31
А вот заметки (мытарства) как я устанавливал и заставил работать последний (несколько дней назад) Viber в дистрибутиве antiX совместимом в Debian - можете посмотреть (и повторить попытаться) здесь - antiX - слабые компьютеры:
Код:
$ inxi -Sxxx
System:
  Host: antix21 Kernel: 4.9.0-279-antix.1-amd64-smp arch: x86_64 bits: 64
    compiler: gcc v: 10.2.1 Desktop: IceWM v: 2.9.7 vt: 7 dm: slimski v: 1.5.0
    Distro: antiX-21_x64-base Grup Yorum 31 October 2021
    base: Debian GNU/Linux 11 (bullseye)
Код:
$ sudo dpkg -i viber.deb
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлено 112034 файла и каталога.)
Подготовка к распаковке viber.deb …
Распаковывается viber (16.1.0.37) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
viber зависит от gstreamer1.0-plugins-ugly, однако:
  Пакет gstreamer1.0-plugins-ugly не установлен.
viber зависит от gstreamer1.0-pulseaudio, однако:
  Пакет gstreamer1.0-pulseaudio не установлен.

dpkg: ошибка при обработке пакета viber (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1) …
Обрабатываются триггеры для mailcap (3.69) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
viber
... а теперь дальше начинается ручная дрочиловка ... причём это проблемы не мои, и не сборщиков дистрибутива, а криворуких создателей Viber!
проблема вся в руках, а не разработчиков вайбера, даже на сраной убунте вайбер запускается с первого раза.