Opera

Olej

New member
Сообщения
670
#1
Хочу свежую Opera, здесь: https://www.opera.com/ru/computer
Код:
olej@astra:~/Загрузки$ sudo dpkg -i opera-stable_60.0.3255.151_amd64.deb
[sudo] пароль для olej:
Выбор ранее не выбранного пакета opera-stable.
(Чтение базы данных … на данный момент установлено 171163 файла и каталога.)
Подготовка к распаковке opera-stable_60.0.3255.151_amd64.deb …
Распаковывается opera-stable (60.0.3255.151) …
dpkg: зависимости пакетов не позволяют настроить пакет opera-stable:
opera-stable зависит от libcurl3 (>= 7.16.2) | libcurl4 (>= 7.58.0), однако:
  Пакет libcurl3 не установлен.
  Пакет libcurl4 не установлен.

dpkg: ошибка при обработке пакета opera-stable (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для menu (2.1.47-astra1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для shared-mime-info (1.8-1) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-1) …
При обработке следующих пакетов произошли ошибки:
opera-stable
Где взять libcurl*?
 

Olej

New member
Сообщения
670
#2
Добавил репозиторий (совместимый) Mint 18.2:
Код:
root@astra:/media/cdrom0# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A6616109451BBBF2
Executing: /tmp/apt-key-gpghome.QJ4vNCgUGM/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys A6616109451BBBF2
gpg: key A6616109451BBBF2: public key "Linux Mint Repository Signing Key <root@linuxmint.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1
Код:
root@astra:/etc/apt/sources.list.d# pwd
/etc/apt/sources.list.d

root@astra:/etc/apt/sources.list.d# touch mint.list

root@astra:/etc/apt/sources.list.d# cat mint.list
deb http://packages.linuxmint.com/ sonya main upstream import backport romeo
Код:
root@astra:/etc/apt/sources.list.d# apt update
Сущ:1 https://download.astralinux.ru/astra/stable/orel/repository orel InRelease
Игн:2 http://packages.linuxmint.com sonya InRelease                                         
Пол:3 http://packages.linuxmint.com sonya Release [24,1 kB]
Пол:4 http://packages.linuxmint.com sonya Release.gpg [819 B]
Пол:5 http://packages.linuxmint.com sonya/main amd64 Packages [18,2 kB]
Пол:6 http://packages.linuxmint.com sonya/main i386 Packages [17,5 kB]
Пол:7 http://packages.linuxmint.com sonya/upstream i386 Packages [45,0 kB]
Пол:8 http://packages.linuxmint.com sonya/upstream amd64 Packages [45,7 kB]
Пол:9 http://packages.linuxmint.com sonya/import amd64 Packages [8.261 B]
Пол:10 http://packages.linuxmint.com sonya/import i386 Packages [8.273 B]
Пол:11 http://packages.linuxmint.com sonya/backport amd64 Packages [72,9 kB]
Пол:12 http://packages.linuxmint.com sonya/backport i386 Packages [73,5 kB]                                           
Получено 314 kБ за 7с (40,4 kБ/c)                                                                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Может быть обновлено 5 пакетов. Запустите «apt list --upgradable» для их показа.
 

Olej

New member
Сообщения
670
#3
Добавил репозиторий (совместимый) Mint 18.2:
Обновлю то чего не хватало:
Код:
root@astra:/etc/apt/sources.list.d# apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libcurl3
НОВЫЕ пакеты, которые будут установлены:
  libcurl3
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 5 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 291 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 635 kB.
Хотите продолжить? [Д/н] y
Пол:1 https://download.astralinux.ru/astra/stable/orel/repository orel/main amd64 libcurl3 amd64 7.52.1-5+deb9u9 [291 kB]
Получено 291 kБ за 0с (828 kБ/c)
Выбор ранее не выбранного пакета libcurl3:amd64.
(Чтение базы данных … на данный момент установлено 171544 файла и каталога.)
Подготовка к распаковке …/libcurl3_7.52.1-5+deb9u9_amd64.deb …
Распаковывается libcurl3:amd64 (7.52.1-5+deb9u9) …
Настраивается пакет libcurl3:amd64 (7.52.1-5+deb9u9) …
Настраивается пакет opera-stable (60.0.3255.151) …
update-alternatives: используется /usr/bin/opera для предоставления /usr/bin/x-www-browser (x-www-browser) в автоматическом режиме
update-alternatives: предупреждение: пропуск создания /usr/share/man/man1/x-www-browser.1.gz, так как связанный с ней файл /usr/share/man/man1/opera.1.gz (из группы ссылок x-www-browser) не существует
update-alternatives: используется /usr/bin/opera для предоставления /usr/bin/gnome-www-browser (gnome-www-browser) в автоматическом режиме
update-alternatives: предупреждение: пропуск создания /usr/share/man/man1/gnome-www-browser.1.gz, так как связанный с ней файл /usr/share/man/man1/opera.1.gz (из группы ссылок gnome-www-browser) не существует
Обрабатываются триггеры для libc-bin (2.24-11+deb9u3) …
Обрабатываются триггеры для menu (2.1.47-astra1) …
Всё!
Имеем Opera.
 

Вложения

Последнее редактирование: