Astra Linux для ДСП/КТ/ПД

kraynopp

New member
Сообщения
11
#1
Хотелось бы узнать у разработчиков, есть ли в планах создание дистрибутива, аттестованного ФСТЭК для ДСП/КТ/ПД. Использовать в этом случае смоленск - всё-таки как из пушки по воробьям, орел - не аттестован. А аналогичного дистрибутива по уровню поддержки и темпам развития, причём с сертификатом ФСТЭК на ДСП - нет.
 

cogniter

Moderator
Team Astra Linux
Сообщения
378
#2
сейчас мы предлагаем использовать Смоленск, вопрос о промежуточном варианте в стадии обсуждения.
 

Mrshll

New member
Сообщения
53
#3
Мне кажется, не стоит этого делать - напрасное распыление ресурсов, совершенно не оправданное. Держите только SE, плавно повышая качество и снижая цену ;-)
 

kraynopp

New member
Сообщения
11
#4
SE - это хорошо, без сомнений. Но адекватный дистрибутив для ДСП тоже нужен.
 

CrashBldash

New member
Сообщения
175
#5
Проголосуют рублем за самый дешевый дистр с сертом фстэк
 

CrashBldash

New member
Сообщения
175
#7
Роман, если вы знакомы с практикой госзакупок, то удивляться не приходится).
К тому же на уровне ФСТЭК Астра, Альт, Роса на данный момент одного поля ягоды. Только вот у астры МС Офис криво еще работает ))
 

CrashBldash

New member
Сообщения
175
#9
На версии .13 та же история с wine но добавили winetricks правда графически он не запускается :LOL:
Вайнтрикс и раньше был. Его обновили, но версия опять же не последняя. Графически он прекрасно запускается, установи zenity.

Но вот после обновления Орла до 2.12.13 из вайтрикса перестал устанавливаться MDAC28, из-за ошибки SHA256. При этом даже если обновить вайнтрикс через вшитый в него обновлятор до последней версии, тем самым отвязав его от репы, то ошибка SHA256 все равно повторяется, что навевает мысль о том что дело тут совсем не в вайнтриксе.....
 

3d3

New member
Сообщения
91
#10
Вайнтрикс и раньше был. Его обновили, но версия опять же не последняя. Графически он прекрасно запускается, установи zenity.
В ,8 егоне было в репозитарии астры, а сейчас это не точно надо посмотреть на репозитаории может я ошибься и у меня прописан дебиановкий. В .13 ругается на разрядность ситемы и в командной строке как я понимаю можно установить модули, не разбирался так ка на нынешнем этапе вайн не нужен но то что в новой версии системы те же проблемы с оболочкой fly что и ранее вставляет.
 

CrashBldash

New member
Сообщения
175
#11
Это проблемы не вайна, а флая. Вот они с ним и кочуют.

Четвертый вайн поддерживает x86, x64 и x32. В астре первые две точно. Чтобы перевести вайн префикс в х86:
$ rm -rf ~/.wine
$ WINEARCH=win32 winecfg
Или другой префикс создайте
 

3d3

New member
Сообщения
91
#12
Я так и сказал что допилить оболочку не могут причем как минимум с начала года. У них часть программ не попадает в меню и ассоциации.

winetricks добавили в репозитарий, я посмотрел у меня только астры подключен.

У вас зен срет подобным?

(zenity:10105): Gtk-WARNING **: Theme parsing error: gtk.css:3693:13: Not using
units is deprecated. Assuming 'px'.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(zenity:10126): Gtk-WARNING **: Theme parsing error: gtk.css:127:35: The style p
roperty GtkButton:child-displacement-x is deprecated and shouldn't be used anymo
re. It will be removed in a future version

(zenity:10126): Gtk-WARNING **: Theme parsing error: gtk.css:128:35: The style p
roperty GtkButton:child-displacement-y is deprecated and shouldn't be used anymo
re. It will be removed in a future version

(zenity:10126): Gtk-WARNING **: Theme parsing error: gtk.css:129:34: The style p
roperty GtkCheckButton:indicator-size is deprecated and shouldn't be used anymor
e. It will be removed in a future version

(zenity:10126): Gtk-WARNING **: Theme parsing error: gtk.css:132:46: The style p
roperty GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be
used anymore. It will be removed in a future version
 

CrashBldash

New member
Сообщения
175
#13
Zenity это грубо говоря ГУЙ для командной строки. Она писалась не для вайнтрикса, он ее просто использует. Если она сыпет какие то ошибки - это пофигу. Главное чтобы работало.