qtcreator

Сообщения
3
#1
sources.list
------------------
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-3 20190216-11:59]/ stretch contrib main
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-2 20190216-11:59]/ stretch contrib main
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-1 20190216-11:59]/ stretch contrib main
deb cdrom:[OS Astra Linux 2.12 orel - amd64 DVD ]/ orel contrib main non-free
------------

#apt-get install qtcreator
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
qtcreator : Зависит: qtdeclarative-abi-5-7-0
Рекомендует: clang но он не будет установлен
Рекомендует: gdb
Рекомендует: qmlscene но он не будет установлен
Рекомендует: qt5-doc но он не будет установлен
Рекомендует: qt5-qmltooling-plugins но он не будет установлен
Рекомендует: qtcreator-doc но он не будет установлен
Рекомендует: qtdeclarative5-dev-tools но он не будет установлен
Рекомендует: qttools5-dev-tools но он не будет установлен
------------------------
Подскажите как решить ...
 

Fd1501h

Moderator
Сообщения
671
#2
sources.list
------------------
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-3 20190216-11:59]/ stretch contrib main
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-2 20190216-11:59]/ stretch contrib main
deb cdrom:[Debian GNU/Linux 9.8.0 _Stretch_ - Official amd64 DVD Binary-1 20190216-11:59]/ stretch contrib main
deb cdrom:[OS Astra Linux 2.12 orel - amd64 DVD ]/ orel contrib main non-free
------------

#apt-get install qtcreator
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
qtcreator : Зависит: qtdeclarative-abi-5-7-0
Рекомендует: clang но он не будет установлен
Рекомендует: gdb
Рекомендует: qmlscene но он не будет установлен
Рекомендует: qt5-doc но он не будет установлен
Рекомендует: qt5-qmltooling-plugins но он не будет установлен
Рекомендует: qtcreator-doc но он не будет установлен
Рекомендует: qtdeclarative5-dev-tools но он не будет установлен
Рекомендует: qttools5-dev-tools но он не будет установлен
------------------------
Подскажите как решить ...
У вас нет интернета на этом ПК?
 

Fd1501h

Moderator
Сообщения
671
#4
Похоже что не все пакеты есть в iso (+в Debian используется старая версия Qt, в Астре новее).
Если подключить репозиторий Астры
Код:
deb https://repo.astralinux.ru/astra/current/orel/repository/ orel main contrib non-free
То для скачивания рпедлагает 124мб